If your school account is linked to the wrong email address in CK-12, it is usually because the email address associated with your LMS or SSO account does not match the email address on your CK-12 account.
This can result in CK-12 creating or connecting to a different account than the one you normally use.
Common Causes
Your school account may be linked to the wrong email if:
- Your school recently changes your email address/domain.
- You have multiple email addresses (such as a personal and a school email).
- You previously created a CK-12 account using a different email address.
- You sign-in through an LMS such as Canvas, Schoology, Google Classroom or Microsoft using a different email than your CK-12 account.
How to Fix the Issue
- Verify your email address
- Sign-in using the correct method
- Check your LMS email
I am Seeing the Wrong Classes or Library
If you notice:
- Missing classes
- Different saved resources
- An empty library
- Missing assignments
You may be signed into a different CK-12 account. Try signing out and logging back in using the correct email address or your school's SSO option.
If you're unable to resolve the issue, please contact CK-12 support (support@ck12.org).